I can't delete "Map Image Layer" from Portal for ArcGIS

1677
2
03-11-2019 02:47 PM
IngJuanMaSuarez
Esri Contributor

Hi everyone.

I have an environment of ArcGIS Enterpise 10.6.1, Federate Hosting Server, Portal, Datastore and 2 Webadaptor.

I publish a service from ArcGIS Desktop to ArcGIS Server, and I try to eliminate it from Portal for ArcGIS but I get an error ("Unable to reach the server where the service is. Consider using calling deleteItem with options = { 'force' : true } if the server won't be available anymore")

I can delete items of Dashboard, WebMap, Shapefile and Feature Layer Hosted without problem, but if it is a service that I published from Desktop, I get that error. I followed the instructions of deleteItem with options = { 'force' : true }, and I can eliminate the item without problem.

Apart from this solution, is there a way to delete items from Portal for Arcgis without having to go to Sharing? Any recommendation, idea or suggestion to find the error and a more direct solution?

0 Kudos
2 Replies
ThomasJones1
Esri Contributor

Hi Juan,

If understand correctly this issue only occurs with Map Image Layers? Is the Map Image Layer published using a registered data source (e.g. SQL, Oracle and Postgre)? If you publish a feature service from a registered data source are you able to delete the item successfully?

I would recommend attempting to delete the problem item. Then review the Portal logs at debug level, hopefully this may provide more information on the cause of issue.

I have seen this problem before in relation to certificate issues. Therefore I would recommend ensuring a valid certificate is imported and configured with Portal, ArcGIS Server and your Web Server.

Import a certificate into the portal—Portal for ArcGIS (10.6) | ArcGIS Enterprise  

Configure HTTPS using a new CA-signed certificate—ArcGIS Server Administration (Windows) | ArcGIS En... 

Thank you,

Thomas.

0 Kudos
EnxhiMasha2
New Contributor

Hi! I’m facing the same problem. I have a federated server with the ArcGIS Server as an hosting server. Also a valid Digicert CA SSL installed on IIS. I can delete the services from arcgis manager or arcgis desktop but not from portal content page. Also i can delete them from sharing with force delete. Did you find any solution or what may cause this?

thankyou in advance

0 Kudos