Select to view content in your preferred language

Bug in Portal for ArcGIS 10.3, Web AppBuilder ?

04-10-2015 02:14 AM
New Contributor III

We have installed Portal for ArcGIS 10.3 on Windows Server 2008.

I encounter the following problem:

I create a simple WebMap, e.g. just adding one layer (e.g. the ArcGIS server test service SampleWorldCities) to the basemap.

Then I create a Web application from this map selecting the Web AppBuilder. I leave everything to the default settings (Foldable Theme).

If I then press first the button of the Legend widget and afterwards the button of the Layer List widget (in the Header Controller), I get the following error (in a popup):

create widget error:


Pressing the Layer List widget before the Legend widget  or using the Tab Theme, everything works fine.



0 Kudos
6 Replies
Esri Esteemed Contributor

Hi Hilde,

The issue you've described is very unusual and we are unable to reproduce it. Some things to help troubleshoot:

- Have you tried to clear your web browser cache?

- What web browser are you using? Does the same thing happen when you use the same workflow in a different web browser?

Hope this helps,

0 Kudos
New Contributor III

Hi Derek,

thanks for your reply. The problem persists in different Web Browsers (Firefox, IE, Chrome) and also after clearing the cache.

Actually a colleague of mine discovered it and I reproduced it. I also tried as a different portal user (administrator), same behaviour.

The portal is installed on an internal server, so I cannot send you the link.

Now I created a new map, just adding

Map Contents



and from this I just create a Web application  (Share --> Make a Web Application --> Web AppBuilder)

I can see this behaviour directly on the Web AppBuilder page leaving everything to the default, pressing first the Legend button and then the Layer List (pressing the other way round everything works).

It seems that something is initialised wrongly.

I am using the Web AppBuilder for the Portal, not the developer edition.


0 Kudos
Esri Esteemed Contributor

Hi Hilde,

I tried to reproduce the behavior your describing with the specific web services (from ArcGIS Online) you listed in your post and I don't see any issues. I suspect that perhaps something may be amiss with your Portal for ArcGIS installation. Please contact Esri Tech Support as they are best equipped to help you investigate and track down the issue.

Good luck,

Occasional Contributor II


I tried to reproduce the bug/issue on my own Portal for ArcGIS installation (10.3.1) but didn't find any bug/issues, just normal operation.

1. Loaded a simple webmap into the Web AppBuilder for ArcGIS

2. Leave everything to default

3. Clicked in Legend button first; all ok

4. Clicked in Layer List button; all ok


Just as Derek pointed out, you should look for ESRI Tech Support because it seems something related to your installation.

MVP Esteemed Contributor

Robert Scheitlin, GISP​ . Any help?

Think Location
0 Kudos
MVP Emeritus

I would recommend as Derek has for you to contact tech support as this sounds like it could be a bug.