Annotation exporting outside data frame V10

4978
63
05-12-2011 07:31 AM
AustinStreetman
New Contributor III
Running ArcGIS 10 SP2, when I export to PDF, annotation from a V9.3 file Geodatabase shows up in the margins of the map, outside of the data frame.
Tags (2)
0 Kudos
63 Replies
janssencanicula
New Contributor
Have you solved your issue? I am having the same problem. thanks.
0 Kudos
AustinStreetman
New Contributor III
No, not yet. I tried creating some test annotation in a Version 10 database and this problem did not occur.

The other test I made was to convert my existing anno to a version 10 database and this did not fix the problem.
0 Kudos
GaryLuke
New Contributor
I am having the same issue also, when exporting to pdf. The problem doesn't occur when exported to a jpg.  It seems to have started after SP2 was installed. I've attched two screen shots: the original mxd and the exported pdf.

Gary
0 Kudos
AustinStreetman
New Contributor III
I have also encountered this problem in a new version 10 database.

Here is a very goofy solution:

  1. In Layout view, create a graphic rectangle that goes out the edge of the page. (can use guides for this)

  2. Create another rectangle the same size as the Data Frame, align to the data frame

  3. Select rectangle 2, then rectangle 1, and choose Drawing --> Graphic Opperations --> Subtract. You will now have a square doughnut graphic that frames your Data Frame.
  4. Send the new graphic to the back

  5. Send the Data Frame to the back

  6. Set the graphic to have the same border you want your Data Frame to have.

Now when you export, the square doughnut graphic will mask anything that hangs out of the Data Frame.
0 Kudos
DavidCizek
New Contributor
Hi, I had the same problem.
I just grouped all layers into one and it works correctly.

Michaela Zemkova
0 Kudos
GaryLuke
New Contributor
Hi, I had the same problem.
I just grouped all layers into one and it works correctly.

Michaela Zemkova


This work around does not work for me. I still get annotation outside the data frame.  ESRI?
0 Kudos
GaryLuke
New Contributor
I contacted ESRI Tech Support and here's thier response:

"I came across a known software defect with the issue. The reference for the software defect is as belows:

NIM067880 - Annotation features display outside of the data frame when exporting a map.

The status of the issue is "NEW" which mean that development team of ESRI will be reviewing the bug. I have added your issue to the software defect. "
0 Kudos
PaulPetersen
New Contributor III
I just started noticing this very same issue for v.10 sp2. I'm sad that everyone else is having to deal with it, but kind of glad that I haven't gone crazy, that this is a known bug. I'll try some of the workarounds. I get it for both v.9.3 and v.10 gdb annotation.
0 Kudos
KarenMiller
New Contributor II
Thanks for the work-around - though goofy, it did the trick!  I'd like to add that I've experienced this problem with layers that are shapefiles as well, though other geodatabase feature classes were also drawn into the map with labels turned on.  Additionally, I've had both labels AND annotation draw outside the dataframe after exporting.  Glad to see its been logged as a bug with severity "High". I hope a patch is released soon!
0 Kudos