OSError: cannot identify image file

4202
11
02-18-2020 10:52 AM
JingyiHu
New Contributor

I have this issue when I try to use prepare_data function. I already have the newest version of pillow.
I also noticed that the tiff files that I get from the "export training data for deep learning" can not be opened .
(constantly showing this)

As fopr the meta data format, I tried labeled tiles, classified tiles, KITTI labels and PASCAL VOC format. None of their output tiff can be opened.

I m wondering how can I fix this? Thank you!
0 Kudos
11 Replies
DavidHarris5
New Contributor

This error persists when the raster is not multi-spectral.  16-bit does not appear to be supported.  And when changing the raster to 8-bit, it does not appear to support RGB rasters.  I have been having many of the issues reported with the deep learning toolset, and any support would be appreciated. Below is an error from the python API when trying to view the labeled objects. 

DavidHarris5_0-1617220856224.png

All the exported .tiff images (I have also tried .png with the same issue) are black squares. They should look something like this:

DavidHarris5_2-1617221875306.png

 

 

0 Kudos
by Anonymous User
Not applicable

hello dear communities
Thanks for the answers
Please I reinstated arcgis pro I received the following connection problem.


2nd problem with the notebook: it does not accept the training data generated by arcgis pro? How to generate them and in what format ?


Thank you

0 Kudos