daprixm

Problem Importing Raster into File Geodatabase

Discussion created by daprixm on Jun 23, 2014
Latest reply on Jun 24, 2014 by jskinner-esristaff
I have been georectifying historic maps and at the moment many of them are in different folders.  I like storing all of my data in a geodatabse regardless of what I'm doing.  I have been doing this for the past year with no issues on 10.1.  I have recently started using 10.2 at an institution where I do not have administrative privileges. 

Nearly every time I try to import a raster to my file geodatabase I get this warning: 

ERROR 999999: Error executing function.
FDO error: -2147024864 [GDB_Items]
No spatial reference exists.
The table was not found. [file name]
Failed to execute (CopyRaster).

All the files have spatial references and, here's the kicker, it'll work the seventh or eighth time I try to import.  I'm not sure what I am doing differently or if there is some lock on the data that is causing this but it is incredibly frustrating.  It seems like running the operation from the contents in ArcCatalog rather than the Catalog Tree works better and refreshing everything repeatedly helps, again though, it takes seven or eight times before that actually works for some reason.

Has anyone else experienced this or has an answer?  It would really help prevent a lot of frustration.


**Update**

So it seems that if I refresh all folders and geodatabases before I run the process the raster will be imported into the geodatabase without any problems.  I would still like to know why this is the only way that I can import rasters without getting an error message

Outcomes