AnsweredAssumed Answered

Spatial Join Annotation Problem

Question asked by gambrels on Dec 17, 2012
Latest reply on Jun 14, 2013 by kgrady
I am having trouble spatially joining selected attributes of a polygon FC to an Annotation FC.  I am doing this so that I can use a Definition Query to control when annotation is displayed on certain polygons.

Both FC's (as well as the resulting FC) are located in the same File GDB.  The FC I am working on is a copy of a perfectly functional Annotation FC in the same File GDB.  The annotation is NOT feature-linked.  I am using 10.1.

The spatial join completes and attributes are correctly transferred from the source (polygon) to the target (Annotation), however there are two problems with the resulting Annotation FC: 
1)  Some of the attribute fields (Anno Class ID, Symbol ID) are lost in the join, resulting in a field of NULL values.
2)  Second, the Annotation will not display (though it IS there - it has rows on the attribute table and I can select in the map).
I have a feeling problem #1 is a result of problem #2.

No matter what I do, I cannot get the annotation to display.  I have populated the Anno Class ID and Symbol Class with valid values, no luck.  I have moved the target FC into a different GDB and re-run the join, no luck.  I have re-created the target FC from scratch in a separate GDB and re-run the spatial join, no luck.  I have tried symbol substitutions, no luck.  I have tried modifying the symbol in the "symbol collection", no luck.  I have changed the size of the symbol as well as the reference scale (just in case it was dsplaying but too small to see), no luck.        

Is there anything else I should be trying?  Is there anything I am missing?  Why won't my annotation display???

Thanks all!

Outcomes