Caleb1987

Problems with Intersect tool in 10.1??

Discussion created by Caleb1987 on Nov 1, 2012
Latest reply on Mar 20, 2013 by khartling-esristaff
Hi all,

I have a script that I run every night that recalculates CSR values for ag land parcels since there are boundaries that change almost every day.  I have not had any problems until I upgraded to 10.1 two days ago.  My script is failing at the Intersect tool every time and I am getting a strange error:

Error Info:
ERROR 999999: Error executing function.
The table was not found.
The table was not found. [Soils_by_parcel]
The table was not found.
The table was not found. [Soils_by_parcel]
Invalid Topology [Topoengine error.]
Failed to execute (Intersect).

I never got this message before and the script ran fine without any problems with v10.  Is this a bug with 10.1? Is anyone else having this problem?  I have read that the intersect tool may crash on large datasets (which the the soil fc is huge), but it worked fine when I had Arc 10 (has been running every week night for the last 3 months with no problems!).  I have changed the XY tolerance, disabled background processing, repairing geometry, downloaded service pack 1, tried it by script, tried it in ArcMap and it STILL fails.

Both Feature Classes are in a file geodatabse and I am running Arc 10.1 (SP1) on windows XP.

Outcomes