frank_mclean

Buffer and %scratchfolder% - "Error 000210: Cannot create output..."

Discussion created by frank_mclean on Oct 24, 2012
Latest reply on Oct 25, 2012 by frank_mclean
This is happening on Windows 2008 R2 Enterprise SP1.

I have built a model in ModelBuilder that (in summary) takes a feature set, does a whole load of spatial unions, buffers the input feature set to 2 miles and then does a final spatial join with that on another feature set.  All the union results are parameters, as is the buffered shape.  I have all the results outputting to %scratchfolder%\quads, %scratchfolder%\project_buffered, etc.  Everything apart from the buffering runs fine.  I am seeing the following when I get to the running of the buffer tool:

ERROR 000210: Cannot create output C:\Users\frank_mclean\Documents\ArcGIS\scratch\project_buffered
Failed to execute (Buffer).

1. The project_buffered shapefile actually seems to be created just fine.
2. I am running ArcMap as an administrator.
3. If I change the buffer output to be something like 'C:\Temp\project_buffered', the model runs fine.  With the issue then, of source, that if I rerun the model, it basically won't, because 'C:\Temp\project_buffered' already exists.

So, my questions are:

1. What's going on? :-)
2. I'm going at all this to get a result so I can publish the model as a service.  If I do a hack like point 3, above, will I be able to publish the service and not worry that whenever it runs it won't use an appropriate scratch area?  By which I mean can I be assured of this, not just try it and see it works and then bet the farm? :-)

Thanks,

Frank

Outcomes