"out of memory" message when i'm using image classification toolbar

610
4
04-17-2012 12:05 AM
gondretkarine
New Contributor
I'm trying to get the histogram of a training sample, with the image classification toolbar, but I get the following error message "out of memory"! I don't know what to do to slove this problem. If someone would give me a solution, I would be very grateful.
thanks

I'm using ArcGIS 10 with Windows 7 Pro (service Pack 1). 64bits
System :
Intel (R) Core (TM) i7-2600K CPU @ 3.40GHz ; RAM = 16Go ,
0 Kudos
4 Replies
ElleryKlein
New Contributor
I am having this exact same problem, using a Landsat Thematic Mapper (TM) image of the Imperial Valley, CA, region. I create a training site, fill out the training sample manager icon, and when I hit the histogram icon, I get an "Out of Memory" message. I see that the service pack was supposed to fix a histogram problem with Landsat images, but I have installed the SP4 already.

Thanks for any advice on this issue!
0 Kudos
XuguangWang
Esri Contributor
Can you try saving your ArcMap session (and your training samples!), and restart ArcMap to see if the issue goes away? In most cases, it should solve the issue.

(To save training samples, use the 'save' icon on the training sample manager.)

Thanks.
0 Kudos
ElleryKlein
New Contributor
Here is a solution that worked for me:

1. Close ArcMap/ArcCatalog, and go to the following folder:
C:\Users\User folder\Application Data\ESRI\Desktop10.0\ArcMap\Templates
Rename Normal.mxt to Normal_old.mxt.

2. Open ArcMap. In ArcMap, click on the 'Geoprocessing' menu (on the main toolbar) > Geoprocessing options > in the 'Background Processing' option area, UNCHECK the 'Enable' option.

3. New test the behavior again.
0 Kudos
JakeSimpson
New Contributor II
I am getting the same problem as you and tried the suggestions in this thread, but to no avail. 

This does not seem to be resolved by freeing space in the geodatabases or by attempting the operation in a new/empty session/geodatabase. I also tried using smaller training samples, but I still get the same error. I have also tried increasing the amount of available memory, but this was also ineffective.

Did you ever resolve the problem and if so, how?  What was the cause?

I'd really like to get on with my image classification!
0 Kudos