Arcpy scripting works in Python window but not in Script

Discussion created by jazmateta on Aug 4, 2011
Latest reply on Oct 4, 2011 by anchorite
Okay, I am really at my wits end now.  The three previous posts were with the script - all written after testing in the python window.  Now I see that I am not having difficulties with the language even if I am just learning it, for these simple tasks, I have gotten the process.

Can SOMEONE please explain why the individual lines of script work in the python window from within an ArcMap session, but DO NOT work when saved as a script to be used as a tool?

The entire script is really quite simple:
After the mxd is opened in ArcMap,
Geocode some data (already know that a composite locator won't work on a Win7 x64 in script)
Update the symbology
Save the geocoded results as a fc in fgd with name_userid_date
Append the geocoded results to an existing fc in fgd with name_year_userid
Then the user prints maps as required

I mean really, this SHOULD NOT be this difficult.  When I tried the geocode portion, discovered that the composite wouldn't run in the script.  Then the update symbology works in window, not in script.  Save the geocoded results to either the current geocoded with date or append to the yearly file, get either an error 582 or the warning 117 of empty set created.

I have tried this on a Win7 x64 Arc10 SP1 machine and on an XP x32 SP3 Arc10 SP2 machine - scripting doesn't work on either one.

Guess the good thing is that we can always teach the new folks how to do the process the old fashioned way and then when we can figure out WHY the script isn't working and get it working then we can give them the tool.