AnsweredAssumed Answered

ArcGIS Pro conda.exe broken

Question asked by Nicholas.Klein-Baer_usfs on Sep 25, 2020
Latest reply on Sep 30, 2020 by Nicholas.Klein-Baer_usfs

It seems that the conda used by my ArcGIS Pro 2.6.1 install is completely broken. I have tried completely uninstalling and re-installing ArcPro, but it didn't change anything. I cannot create environments from the ArcPro GUI, nor can I run *any* conda commands from that python command prompt. For example, when I try running any of these commands:

 

conda list
conda info --envs
conda create --clone arcgispro-py3 -n myenv

It 'thinks' for a few seconds but the simply returns to a new command prompt without doing anything. No text output, nor are new environments created. I know it's not an issue with my PATH environmental variable: I've checked that it's set correctly, and even explicitly calling conda.exe with the full path does nothing :

 

I'm lost on how to fix this. Given that reinstalling did nothing, I suspect it is some problem with my system and not with arcpro or conda themselves. I do have a separate anaconda installation on this machine, which I have been warned can cause problems. Yet on a second machine I use with an almost identical set up (2.6.1 w/ separate Anaconda install) this is not a problem, and it was not a problem on this system until recently.

 

Any thoughts on how to diagnose and fix this?

Outcomes