bz89

ExtractMultiValuesToPoints Returning Point Feature Class Identical To The Input With No Added Fields or Values

Discussion created by bz89 on Apr 14, 2020
Latest reply on Apr 14, 2020 by bz89

I have a point feature class, stored in memory, i have 5 rasters, stored in memory. I can extract the values of each individual raster with the point feature class using the ExtractValuesToPoints function with no problems. However, when i try and run ExtractMultiValuesToPoints, it runs VERY quickly (like 10 seconds) and returns a feature class that contains no new fields and no new values extracted from the raster, no errors are raised, nothing. I have tried defining the field name for each raster and passing that in the list with the rasters. I have tried not passing a field name. I have tried passing the raster result objects. I have tried passing the "in_memory" text path of the rasters. Same result no matter what i try. Has anyone else experienced this, i can find nothing on this or any other forum.

Thanks.

Outcomes