AnsweredAssumed Answered

Button user input doesn't work with line data.

Question asked by njohnson@cnlm.org on Jan 29, 2020
Latest reply on Jan 30, 2020 by njohnson@cnlm.org

We have a button that starts a track log (line data). We cannot configure button user input for the line data. We've tried multiple data types (coded values, single line text, etc). Everything seems fine in Designer, including glancing at the JSON. When you open the project on a mobile device to capture data, and click on the button to begin taking a line, there is no pop-up dialogue box to enter the button user input data.

 

We've tested this a bunch, including using different line feature layers. Button user input isn't working with any line feature. However, button user input can be configured successfully for point data in the same project. We haven't tried with any polygons.The projects we've tested all populate data into a single hosted feature service. I believe the feature layers are all set up appropriately.

 

We also tested project user input for line features and it works as expected.

 

Any ideas?

Outcomes