AnsweredAssumed Answered

Exception: This module requires fastai, PyTorch and torchvision

Question asked by vvivekn_NCSU on Jan 15, 2020
Latest reply on Jan 19, 2020 by s.kumar-esristaff

Hi,

I,m trying to implement building footprint detection using Deep Learning as shown in this example Extracting Building Footprints From Drone Data | ArcGIS for Developers with my own data. But I'm getting the following error when I run the prepare_data() function.

 

 

The command I ran was 

The packages that I'm using in my environment is shown below. This environment was created by cloning the default arcgis environment (ArcGIS Pro 2.4.3)  from the Python package manager and then manually installing the packages (using pip) that were missing when compared to an environment that was created using the command  'conda install -c esri arcgis deep-learning-essentials --no-pin'. Please note that the missing packages that were installed were the latest versions and not the same versions as that of the environment created using the above command.

 

 

Any suggestions, comments or solutions are welcome.  

Outcomes