AnsweredAssumed Answered

Vector tile basemap not printing

Question asked by bb1769 on Nov 4, 2019
Latest reply on Jan 23, 2020 by mmenestrina

I'm unable to get vector tile basemaps to print. Even with a very simple request that only includes the vector tile data, the request succeeds, but the map is blank and the vector tile basemap does not print. The request includes a very long imageData string, which is how I take it that the vector tile printing is handled. The request is being sent from the JavaScript API version 3.29.

 

I've tried printing the standard Esri topo-streets and topo-vector services, as well as the Esri OSM-vector service (added as a custom basemap).

 

If I capture the Web Map as JSON from the browser debugger and use it directly in the print service REST (services directory) form, I get the same result. I've tried the print with print services at version 10.7.1, both a standard print service and a custom service created in ArcGIS Pro. I've also tried it in the sample print service at http://sampleserver6.arcgisonline.com/arcgis/rest/services/Utilities/PrintingTools/GPServer. I understand vector tile printing was supported as of 10.6.

 

I've attached a Web Map as JSON string that I've tested, which includes data from the topo-vector service as generated by the JavaScript API. Any ideas or suggestions on how to debug the request are appreciated.

Attachments

Outcomes