AnsweredAssumed Answered

Problem adding custom basemap to Survey123

Question asked by adailey_slo on Sep 5, 2019
Latest reply on Sep 18, 2019 by adailey_slo

UPDATE for anyone who has the same question I did:  I found out that it is not currently possible to add a Pictometry/Eagleview imagery basemap to Survey123.

-------------------------------------------------------------------------------------------------------------------------------------------------------

ORIGINAL POST:

 

I need to add my organization's aerial imagery basemap to a survey I created using Survey123 Connect, but I'm running into problems--my changes to the .info file totally disappear when I re-publish the survey.

I already read a couple of GeoNet threads about this, plus this Esri page: Prepare basemaps for offline use—Survey123 for ArcGIS | ArcGIS  and this one: Include a map in your survey—Survey123 for ArcGIS | ArcGIS 

 

The .info file associated with my survey seems a little different from the sample on the above webpages, in that mine includes a line about the default map (I want my default to be World Topography, but I want my own aerial imagery to be an option that the users can select when using the survey).  So I had to make a wild guess about where to place my "mapTypes" section.  Maybe this is part of the problem?  

 

Here is my .info file with my custom basemap added into it.  I checked the syntax online with JSONLint, which was very helpful.  Nothing in my survey/settings "breaks" when I try to use this .info, but the problem is that my desired basemap is not added in any way at all, and when I go to check on the .info file after re-publishing my survey, the .info file has gone back to how it was before I added my custom basemap!  The stuff I added simply disappears (the "mapTypes" section).  How do I get it to stick??

 

(Note: my URL is complete; it appears incomplete below due to where my screenshot cut it off.)

 

Outcomes