AnsweredAssumed Answered

support with python 27

Question asked by meghan.kulkarni_Superion on Dec 31, 2018
Latest reply on Jan 2, 2019 by DUrbach-esristaff

Hello ESRI Team,

 

I’m trying to get ArcGIS API for Python locally installed on my workstation. My workstation config is as follows:

 

  • Windows 64-bit OS
  • Python 27 (which comes along with ArcGIS 10.5.1)

 

I used the command prompt to navigate to Scripts directory C:\Python27\ArcGIS10.5\Scripts>

 

pip install arcgis

 

. I’m getting below error:

 

C:\Python27\ArcGIS10.5\Scripts>pip install arcgis

Collecting arcgis

  Using cached https://files.pythonhosted.org/packages/6e/e3/a0da48d939ac81ac11921a6cd386d98b5c75d75b633a7959d78ae4bfe311/arcgis-1.5.2.post1.tar.gz

    Complete output from command python setup.py egg_info:

    running egg_info

    Running post-install...

    No handlers could be found for logger "root"

    C:\Python27\ArcGIS10.5\lib\site-packages\setuptools\dist.py:470: UserWarning: Normalizing '1.5.2-post1' to '1.5.2.post1'

      normalized_version,

    Traceback (most recent call last):

      File "<string>", line 1, in <module>

      File "c:\users\meghan~1.kul\appdata\local\temp\pip-install-uzcrw5\arcgis\setup.py", line 272, in <module>

        setup(**kwargs)

      File "C:\Python27\ArcGIS10.5\lib\site-packages\setuptools\__init__.py", line 143, in setup

        return distutils.core.setup(**attrs)

     File "C:\Python27\ArcGIS10.5\lib\distutils\core.py", line 151, in setup

        dist.run_commands()

      File "C:\Python27\ArcGIS10.5\lib\distutils\dist.py", line 953, in run_commands

        self.run_command(cmd)

      File "C:\Python27\ArcGIS10.5\lib\distutils\dist.py", line 972, in run_command

        cmd_obj.run()

      File "c:\users\meghan~1.kul\appdata\local\temp\pip-install-uzcrw5\arcgis\setup.py", line 120, in run

        super().run()

    TypeError: super() takes at least 1 argument (0 given)

 

    ----------------------------------------

Command "python setup.py egg_info" failed with error code 1 in c:\users\meghan~1.kul\appdata\local\temp\pip-install-uzcrw5\arcgis\

 

FYI: I have updated my setup tools. My question is that ArcGIS API for Python not supported with Python 27?

 

My Best,

 

Meghan Kulkarni

Outcomes