AnsweredAssumed Answered

Permission error configuring arcgis data store 10.6.1

Question asked by einar.dorheimgeodata-no-esridist Employee on Jul 25, 2018
Latest reply on Jul 26, 2018 by einar.dorheimgeodata-no-esridist

Hi

 

I had arcgis enterprise 10.6 installed on my computer, single machine setup, basic settings, installed with Enterprise builder. Configured Datastore for Relational and Tile Cache. I tried to upgrade my enterprise to 10.6.1 and ran into some troubles. 

 

Firstly the enterprise builder for 10.6.1 ran through and upgraded my applications, telling me everything was OK and upgraded except my Portal. So to fix this i downloaded the setup file for  Portal for acrgis, installed it and configured the web-adaptor. So far so good. I can log in to both the portal and the federated server. 

 

However, I noticed that none of my hosted feature layers didn't work, and that I got a red exclamation point when trying to validate the server/data stores. 

 

So I tried to run the Arcgis Data Store Configuration Wizard and run in to this little error message: 

Runtime error detected on one or more operation on the configuration store, with message:'{0}'.. Extended error message: Failed to get file permission

Which suggest the user doesn't have the right permissions, so I gave admin user account full priveliges for the following directories(included subdirectories) : C:\arcgis\arcgisdatastore, C:\arcgis\arcgisportal, C:\arcgis\arcgisserver,  C:\inetpub\wwwroot\portal, C:\inetpub\wwwroot\server, C:\Program Files\ArcGIS (subdirectories: DataStore, Portal, Pro, Server) and C:\python27. Basically every directory related to the enterprise. 

 

When trying to validate the Data Store through the ArcGIS Server Administrator Directory with 

Relational data store: data > items > enterpriseDatabases > <data store name> >machines > <machine name> > validate

I get this message: Server machine 'https://(Machine.Name):2443/arcgis/datastoreadmin/machines/PC-(Machine.Name)/validate' returned an error. 'Data store hasnt been created on this machine.'

 

 

Get Error msg 404 unable to get ...:2443/arcgis/help/nb/cxhelp.xml

 

 

Have tried to run a repair on the Data Store installation - no success.

Have tried with running the config wizard for datastor with both localhost url and url with machine name, results in same error message. 

 

Any suggestions?

Outcomes