AnsweredAssumed Answered

Python Shell 64-bit

Question asked by Dane_Stephenson on Dec 4, 2017
Latest reply on Dec 5, 2017 by Dane_Stephenson

Is there a way to force the IDLE Shell installed with ArcGIS to use the 64-bit processing over the 32-bit processing?  I have the 64-bit background geoprocessing extension installed. 

 

I need to be sure that the script tool that I have written will run in the 64-bit background geoprocessing and the IDLE Shell is nice to run scripts you are testing in since it stays open after execution and will display errors.  I have a script tool that will execute in 32-bit.  I have modified it to include a portion that executes an FME Workspace.  It will run everything up unto the FME Workspace execution.  I get an ImportError stating that it is not a valid 32-bit application.  I assume this means that it wants to run the workspace in 64-bit.  I would prefer to run the tool in the background anyway.  However, when I uncheck the "Always run in the foreground" option on the script tool properties and run it, it fails immediately and does not complete any of the portion it did while running in the foreground.

 

Any help would be greatly appreciated.  Thank you in advance.

Outcomes