AnsweredAssumed Answered

Unable to Delete Versions

Question asked by apurvdanke on Oct 12, 2017
Latest reply on Oct 12, 2017 by asrujit_pb

Hi,

 

We are using Oracle12c for our enterprise geodatabase at 10.4.1 and we're maintaining versions using OS authentication. All the users create their own versions using OS authentication. Now, when we want to delete some of the versions for housekeeping, we need to ask those users to delete their own versions, as (I think) only the version owner can delete their versions. Now, we may face an issue which is if someone leaves the organization, and the corresponding user id which is used to logon to the systems becomes disabled, and the user didn't delete his/her versions and they are left over, then how do we as administrators delete them. I have tried using the respective user-defined schema owners, where we have kept our datasets, and tried to delete those user versions using the schema owner, but the geodatabase still does not allow to delete them, even though the versions are marked as "Public". Bear in mind that the versions created using OS authentication are named as "WindowsLoginUserName".<VersionName>, while those created using DB authentication (schema owner) come as <SchemaOwnerName>.<VersionName>. There are no double quotes if we use database authentication.

 

So is there a way to delete the versions, belonging to a user, whose ID may have been disabled?

 

Regards,

Apurv

Outcomes