AnsweredAssumed Answered

Local rout task initialize error on IOS and on Appstudio player mobile version

Question asked by tustht on Aug 6, 2017
Latest reply on Aug 8, 2017 by NManocha-esristaff

Greetings,

 

Kindly note that I'm using local route sample from esri  Qt . I was run it on the AppStudio player on windows version the  route was generated successfully .but when I run it on app studio player on mobile version (android/ios) the route generate error messege ("Route not initialzed")  and doesn't working where note that I copying the route files in its location on mobile (users/ArcGIS/Data/SFnetwork/Runtime .geodatabase).

 

  LocalRouteTask {

        id: localRouteTask
        network: "Streets_ND"
        database: "~/ArcGIS/Runtime/Data/SFnetwork/RuntimeSanFrancisco.geodatabase"
        onSolveStatusChanged: routeSolve()
    }

 

While when I build it on android the route working fine , but on ios get "Route error initializing" error msg  where that means error in the declaration of the database path !!! also on Appstudio player mobile version get same error (Route not initializing).

 

Please help me to fix this error on ios ?or give me sample working fine on ios to make it same of it .Please find the attached sample code .

 

Please help me . Thank you in advance.

 

Best Regards,

Hisham Shrideh

Attachments

Outcomes