Local rout task initialize error on IOS and on Appstudio player mobile version

08-06-2017 12:46 AM
New Contributor


Kindly note that I'm using local route sample from esri  Qt . I was run it on the AppStudio player on windows version the  route was generated successfully .but when I run it on app studio player on mobile version (android/ios) the route generate error messege ("Route not initialzed")  and doesn't working where note that I copying the route files in its location on mobile (users/ArcGIS/Data/SFnetwork/Runtime .geodatabase).

  LocalRouteTask {

        id: localRouteTask
        network: "Streets_ND"
        database: "~/ArcGIS/Runtime/Data/SFnetwork/RuntimeSanFrancisco.geodatabase"
        onSolveStatusChanged: routeSolve()

While when I build it on android the route working fine , but on ios get "Route error initializing" error msg  where that means error in the declaration of the database path !!! also on Appstudio player mobile version get same error (Route not initializing).

Please help me to fix this error on ios ?or give me sample working fine on ios to make it same of it .Please find the attached sample code .

Please help me . Thank you in advance.

Best Regards,

Hisham Shrideh

0 Kudos
1 Reply
Esri Regular Contributor

Hi Hisham,

LocalRouteTask requires "Standard" runtime license with version 10.2.6. Have you initialized the Standard license through code? When running such apps in Player you will need to provide the license via code in your app before you initialize/use any runtime objects. Refer to the link below to get information and code required to do the same.

License your app—ArcGIS Runtime SDK for Qt | ArcGIS for Developers 

Please also refer to two other threads which the similar post

AppStudio Player unable to edit features in .geodatabase ? 


I hope this helps.


0 Kudos