AnsweredAssumed Answered

Arcmap processing error

Question asked by oskarello on Mar 29, 2017
Latest reply on Mar 30, 2017 by oskarello

I am using Arcmap 10.4 with 3d-Analyst on Windows 7 / 64 bit with 32G RAM. Background processing is enabled and 32-Bit (for some reasons).

I used the Function "Interpolate shape" with a 32-Bit-floatingpoint-raster surface datset in a file gdb, and a point shape.

The raster surface is quite (spatial) big; in the properties it says it's uncompressed size is 56GB, but because of it being composed of about 500 small islands (corresponding to 500 points in the shape) of data, and the rest are empty cells, it's not a big dataset.

 

The operation failed at first with "Error 000229: cannot open [resulting shapefile name]"., though the resulting shapefile was created, but empty (no geometry). I tried then to create the feature class in a database, but with the same result.

 

After some thinking what I could have done wrong, I shutted down ArcMap (like many years ago when something alike happened), and restarted it, and loaded my map again.

Then I deleted the faulty shapefile from the result before, and restarted the operation directly from the results, which succeeded.

 

It seems that there is a memory problem ? Even if the calculations are done in an own process outside Arcmap ? - I had 10.1 on an 8 GB machine for a long time, and I cannot remember something like that happening, maybe with 10.0, but for sure before, in the 9.x times.

If the 32-Bit-background-processing would be responsible, I could understand it, if the operation never succeeds, but it does, yet just after a reboot of Arcmap.

Outcomes