Renaming A File GDB

2820
16
09-09-2016 02:46 PM
Occasional Contributor II

Has anyone else experienced problems with creating a file geodatabase clicking off of the FGDB and then trying to rename it and receive an error stating:

"Rename Failed - Failed to rename selected object(s) - General function failure"

Experiencing the issue and have tracked it down to the McAfee anti virus that is installed on the server.

If you wait a few minutes you can rename the FGDB - but sometimes it will still throw the error.

Tags (2)
16 Replies
Honored Contributor

Although many issues with the application may point to the anti-virus (especially when antivirus is installed after installation of ArcGIS), you could also check if you have any of the conditions mentioned in Error: Failed to rename selected object(s) 

MVP Esteemed Contributor

I've been fighting this same issue last past couple weeks with a couple of my scripts. every time I think I have it resolved, I run into it again.  

The timing issue I think is part of the problem. I'm not sure in my case if it is our Mcafee or just network lag.  It seems ArcGIS thinks it is complete faster than the network/OS does...which doesn't make sense, but it does.

I realize you didn't mention if yours is a manual process, or a python script, but here are a few things ran into and have tried:

  • ran on local server, but had issues when running from remote machine.  I've added a "sleep" delay for example for 10 seconds
import time
time.sleep(10)‍‍‍‍‍‍
  • Unknown locked files I didn't know about (other staff had connected at one point that I was aware of.  Found a thread that mention using the    FSMGMT  command (use the search on the OS start button to find it).  This let me find that issue.
  • when I tried the copy-delete rough instead of renamed, it sometimes wiped out all the files from the old folder except the "timestamps" which has a lock I can not track down.  This makes the old name look like a folder instead of a fgdb. Copying (using OS copy) the files from a backup version restored the fgdb, but still can not delete.  I'll be dealing with this one next week again.
  • again in searching and testing many things on geonet and SE, I've found several scripts to clear memory, and to try to find the locks and shut the locking Arc- session down.  I haven't had a lot of consistent  the luck with these, so that comes back to something on my network.   Seems like it's working and I think I can move one...just to have it stop working after a few more test runs. .....which may indicate I am causing the issue, or at least making it worse as I develop and debug.

So whether our anti-virus or network lag, there is defiantly something that is causing rename, and even copy/delete (or in my situation it would be...  Delete-copy-delete-copy) to have issues and not do a complete cleanup.

So, to answer your question re: has anyone else experienced it...yes definitely....and very frustrating.  So I'll keep watching the thread.  By the way.....using 10.2.2 and 10.3.1.

Added note: btw - although helpful as an initial explanation of the error, the link Jayanta Poddar‌ list really doesn't help solve the issue if it's anything beyond permissions or you don't know who might have it open.   That is the hard part....especially when the "open" lock might be caused be a process in the same script.   Also, I should mention, if I have the permissions and it's not open, I had no problem renaming manually....only within a script.

9/12/2016 added note:  another tool is mentioned in this thread https://community.esri.com/message/634133-re-error-arcgis-server-site-is-currently-being-configured-...    by Jon Stainthorpe    re: another Microsoft utility to help locate locks looks promising, and I'm going to see if it helps my issue.  Process Explorer 

Occasional Contributor III

Hello,

While  you are trying to rename the selected object at that time FGDB locked or in use by some of other process like antivirus scan, open or accessing on other application.
Please check .lck file exists in FGDB.
As per suggestion  add folder which contains FGDB in anti virus  exception which excludes the real time scanning for this folder. 

Reply
0 Kudos
Occasional Contributor II

Tried works but not all the time - create many different FGDB's in many locations as scratch and work files daily - pulling the FGDB across to my local work station solves the problem but means I have to move work files around quiet a bit during the day

Reply
0 Kudos
Occasional Contributor II

Jayanta:
No conditions exist that you mentioned in your link

Rebecca:
Yes, the issue has come up in the last 3 weeks – have determined updates to the McAfee seem to be the culprit.
Timing is an issue – network latency / lag
If you hit the error and crash close Arc Catalog, then use Windows File Explorer to disconnect the network share you will get a message that you still have open files.
Not running a script just using the normal rename command - yes have ran into all of the conditions you mentioned - network latency.
Working with our network security determined it was / is McAfee – have went to the extreme of uninstalling the McAfee off the server – the problem goes away totally.
Have determined it is related to the THREAT PROTECTION module in McAfee:
Disabled Accesses Protection, Exploit Prevention, and On-Access Scan
Have pretty much pinned it down to the Access Protection / On-Access Scan sub modules.
Have tried exclusions with some positive results but not consistent.

Avinash:
Advanced user - no; no one else is locking the FGDB.


9/19/2016
Opened a ticket with ESRI tech support

9/13/2016
Esri Case #01827362 - Issues Renaming File GDB Customer Number

Their recommendation was to:

Have you whitelisted all of the Esri/ArcGIS directories?  I would recommend:

C:\Program Files (x86)\ArcGIS
C:\Program Files (x86)\ArcGIS\Desktop10.x\bin
C:\Users\**UserAcct**\AppData\Roaming\ESRI
C:\Users\**UserAcct**\AppData\Local\ESRI


White listing the ENTIRE ArcGIS directories does not work either

Posted in the forums to see if anyone else has experienced the issue and possibly found a work around or resolution - will be contacting McAfee also

New Contributor III

I've found the Unlocker application to be useful to make file geodatabases and shapefiles become unlocked.

Reply
0 Kudos
MVP Esteemed Contributor

Based on all the comments in the Comments section for Unlocker, you may want to rethink that.  It may not be an issue, but our IT folks wouldn't be too happy based on some of these comments.  The Process Explorer   from Microsoft is still probably safer.....however, I'm still not able to find what is locking my fgdb files when they become corrupt due to an incomplete rename and/or delete/copy process.  Only solution in my case is to restart ArcGIS Server.

Reply
0 Kudos
New Contributor III

Great point, Rebecca. Like a lot of free software, various download sites have added their own (in some cases, malware) 'enhancements' to Unlocker. Getting the original Unlocker app (1.9.2) seems to be safe, and that's the version I use. But again, before installing any software, checking it via Symatec or Malwarebytes or other reliable virus checker is always a good thing. In all the years I've used Unlocker, it's never failed me.

Reply
0 Kudos
Occasional Contributor II

The whole issue revolves around the FGDB being locked by in this case McAfee - it takes anywhere from 1.5 to 9 minutes for the lock to release and enable renaming  - using a 3rd party application to unlock the FGDB is not a real solution - the real solution is finding out why or what is causing in my case the McAfee to lock the FGDB like it does.

From the IT stand point 3rd party toolsets like Unlocker can create more problems than they solve.

Everything worked fine until about 3 weeks ago when the locking/ renaming issue showed up.

Reply
0 Kudos