AnsweredAssumed Answered

Fix for corrupt Feature Class in file GDB?

Question asked by Daryl.Hochhalter on Feb 1, 2017
Latest reply on Sep 12, 2018 by FugroGermany

Using ArcGIS 10.4, I have a point feature class in a file GDB that is somehow corrupt. I've tried Recovering the File GDB, that feature class comes back empty. I've tried uncompress, it tells me nothing is compressed even though the command should be dimmed out in that case. I've tried deleting and recreating the spatial index. When I try to export the data I get an error or it exports 2632 features even though the table says it has 2951 features. copy and paste fails when I choose paste from the popup menu with the error "copy failure". You can't see the missing features (features that won't export or import or paste) in the map, just that the table says they are there and you can select all and get 2951 of 2951 features. Even if you export just the table, you get 2632 features in the output table.

I tried adding fields to the table so I could calc geometry, but after adding field to the table it then shows only 2632 records.

 

Any help recovering 300 points would be appreciated!

Outcomes