AnsweredAssumed Answered

ESRI Maps for SharePoint 2013 version 4.1 - bad Installation with no errors

Question asked by on Jul 18, 2016
Latest reply on Jul 25, 2016 by



I've spent 2 full working days already on trying to understand what's the problem with the installation of ESRI Maps For SharePoint 2013 Version 4.1. I've found several conclusions with no real success of running it.


A short summary on how it began and where i'm at today -

1- I installed it in our testing environment as a separate website and the installation and configuration passed smoothly.

2- Then we decided to install it on the existing SharePoint website (same testing environment) and once again, it went smooth and perfectly fine - including configuration and running the component as a webpart.

3- Today we installed it at our stage-integration environment and all the troubles came.


The first issue I experienced was a missing library called 'scripts', which apparently its a huge important library that makes the component actually run. I discovered this when I tried loading the configuration page and saw nothing but a blank white page. I opened up Fiddler and then it showed that the page is trying to reach a missing resource (404) inside a missing library called 'scripts'.


At this point already it's clear to see that there's a major problem with the installation itself which shows no errors!

Apparently, the libraries structure design is defected, since the libraries structure is too deep for windows to handle the file names at some point inside the 'scripts' library.

After many hours of attempts and investigations, I just copied the library from the dev' env' to the integration env'.

Since there is a length limitation by Microsoft, I had to bypass this problem by copying the 'scripts' library to a local root drive, and then MOVE the library to its SharePoint destination path -- copying it there is impossible! It skips 30 files which are too long to handle.


After I successfully copied the missing library, the pages started to show up, BUT with a new error!

This time the error was about permissions to the resource even tho we used admin user (tried several different users as well).

Again, spending many hours and attempts to reinstall or change permissions in the libraries, we eventually understood its something deeper beyond the file system, and then we found the permissions module which the installation suppose to create in the SharePoint administration site, inside a Secure Store Service module.


We found that the first installation attempt, at the development env' was successful and it created values inside an existing Secure Store Service there, but at the integration env' it failed to create those values! which explains the permissions error.


Creating them manually didn't worked. We tried to delete the service as well and recreated him and still it didn't helped.


We reinstalled the component again several times, and still It fails on creating the needed values inside the Secure Store Service without showing any errors at the installation process!


At this point we lost all hope with using this component and sadly, we managed to recreate the problem in the testing environment - we uninstalled it there, ran the installation again (where it worked perfectly fine) and the values in the service were not created.


If anyone have a clue what might be missing here I'd be happy to try but basically it seems that ESRI should make some drastic changes in the installation process!