AnsweredAssumed Answered

Adding Photo Attachments with iOS devices

Question asked by Caleb1987 on Dec 16, 2015

I may be losing my mind here, but I just have a general question.  A few months ago (probably late September or early October) I was testing an app (copied verbatim from an Esri sample) on my iPhone and iPad and noticed the attachment editor widget would not upload attachments when using an iOS device.  It would just hold the thumbnail next the the "Browse" button but it would never upload.  I tested the same app on a colleague's Android device and was able to upload photo attachments.

 

I was using the code from the Samples page for the "Attachment Editor" that previously used the San Francisco 311 sample service.  I just went back to the Sample page for the Attachment Editor today to find a completely different app that now uses the JS API version 3.15 (was referencing 3.14 last time I saw) with a different feature service.  So today I copied the code verbatim from the sample and I can now upload photos from iOS.  It is also worth noting at the time of testing before, I was using iOS 8.1 (I think) and have since updated to iOS 9.1 and I am now able to upload attachments through the Esri widgets. 

 

So my question is, does this work now because of iOS updates?  I was under the impression Safari did not have any sort of file picker support? I believe this update is related to the iOS update because I can change the JS API reference back to 3.14 and I am still able to add attachments from my iPhone.  I tried looking at what's new with the iOS 9.x updates and couldn't see anything about file uploads through browsers.

 

Am I crazy?  Has this always worked and there was an error in the old Sample?  Unfortunately, I copied over the code I had for the old sample, but I didn't really see any issues with it (also, since it worked on Android I'm pretty sure it was fine).  Sorry if this is a dumb question.

Outcomes