AnsweredAssumed Answered

ArcGIS_Runtime_SDK_DotNet_1026  upgrade problems

Question asked by olgalucha on Jul 31, 2015

My application stopped displaying the map after upgrading to
ArcGIS_Runtime_SDK_DotNet_1026 (from 10.2.5). Queries and Identify still work,
but the map and layers won’t display. To try to figure out what the problem
might be, I created a Hello World application:

<Window x:Class="Trial1026.MainWindow"

       xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"

       xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"

       xmlns:esri="http://schemas.esri.com/arcgis/runtime/2013"

       Title="MainWindow" Height="350" Width="525">

    <Grid>

        <esri:MapView x:Name="MyMapView" 

                     Grid.Row="0"
Grid.Column
="0">

            <esri:Map x:Name="MyMap">

                <esri:ArcGISTiledMapServiceLayer ID="BaseMap"

                                                ServiceUri="http://services.arcgisonline.com/arcgis/rest/services/World_Physical_Map/MapServer"
/>

                <esri:FeatureLayer ID="Incidents">

                    <esri:ServiceFeatureTable ServiceUri="http://sampleserver6.arcgisonline.com/arcgis/rest/services/SF311/FeatureServer/0"
/>

                </esri:FeatureLayer>

            </esri:Map>

        </esri:MapView>

 

    </Grid>

</Window>

When I run this app, all I see is the esri logo. If I
comment out either of the layers the result is the same. If a comment out both
layers the only difference in what I see is the background color (w/o layers is
white, with layer is beige).

Ironically, the first thing I noticed after I upgraded the Esri.ArcGISRuntime
reference was that the designer now displays a map, which I thought it was
cool. But it stopped being cool when I run the app and my map does not display.

 

BTW, I’ve uninstalled and reinstalled several times and in
different snapshots of my VM with the same results. However, several colleagues
who are using VMs that originated in the same copy, installed and upgraded
their apps w/o problems, and my hello world app works in their VMs.

Outcomes