AnsweredAssumed Answered

Questions about Database and ArcSDE

Question asked by Schlomm_1 on Aug 19, 2013
Latest reply on Aug 26, 2013 by geonetadmin
Hello,
Over the weekend I've worked on setting up a database for my ArcGIS Server to enable WFS and Feature Access (editing, deleting, updating, creating features/attributes)
Some relevant information:

  • ArcGIS 10.2 installed on Windows Server 2012

  • PostgreSQL 9.2.2 64Bit is installed as well as PostGIS 2.0 http://resources.arcgis.com/en/help/system-requirements/10.2/index.html#//015100000075000000

  • I've copied the necessary 32Bit client files into the \bin-Directory of my ArcGIS Desktop 10.2 installation.

  • I've copied the necessary 64Bit client files into the \bin-Directory of my ArcGIS Server 10.2 installation. I'm even not sure, if I need this....

  • I've copied the necessary st_geometry file into the \lib-Directory of my PostgreSQL 9.2.2 installation.

  • I've registered the database and the folder via the ArcGIS Server manager in the data store tab. (see attached screenshot).

  • The connection via pgAdmin work. I can connect to the database using pgAdmin.

  • The connection via ArcCatalog-> Add Database Connection is finally working. I can connect to the database.


No I'm at the point, where I have to create a Enterprise Geodatabase: http://resources.arcgis.com/en/help/main/10.2/index.html#//002p000000t4000000
I've filed in the required fields and the wizard tries to creta Enterprise Geodatabase for a long while, but doesn't come to an end. It stucks at the last step:

Executing: CreateEnterpriseGeodatabase PostgreSQL myarcgisserver,4321 ghana DATABASE_AUTH postgres ***** SDE_SCHEMA sde ***** # C:\Users\Schlomm\Desktop\keycodes
Start Time: Mon Aug 19 12:50:14 2013
User has privileges required to create database objects.
Geodatabase admin user created.
Database created.
Validated authorization file.
User has required privileges for geodatabase setup.
XML support is enabled for the database instance.
Connected RDBMS instance is setup for Esri spatial type configuration. For now about 20 minutes without any change.


My goal: Being able to set up and use Feature Access and WFS services.
So...are my performed steps right or did I miss anything?
I've read about path variables and enabling geodatabases, but I don't know what and how to perform these steps.
Additionally it would be very nice, if someone could tell me the advantages of using ArcSDE. For now I haven't installed this.


Would be nice, to hear some tips.
Thanks in advance,
Dominik

Attachments

Outcomes