Build modules in Python

172
1
11-09-2020 11:46 PM
AlbertFranc_Scheriani
New Contributor

Hello to all friends
I wanted to know if the Python version with which we wrote the module and did everything was different from the Python version with which we want to install the module.
Thank you for your help.

Tags (1)
0 Kudos
1 Reply
DanPatterson
MVP Esteemed Contributor

Models in Arcgis Pro can be saved to prior versions so that covers the python 3.6 to 2.7 aspect

ModelBuilder: migration to ArcGIS Pro—ArcGIS Pro | Documentation 

There are tools available to consolidate toolboxes

Consolidate Toolbox (Data Management)—ArcGIS Pro | Documentation 

But I wouldn't worry about what happens as python moves to 3.7, 3.8 etc, because the tools that rely on arcpy will have python version checks


... sort of retired...