How to activate editing features?

2982
9
10-27-2017 06:32 AM
AlexanderKrawczyk
New Contributor

I am new in ArcGIS and I do not know how to handle this problem.

I've got a map and I'd like to add some new features. But whatever I do, the editor is always "deactivated".

I've created a new Geodatabase and created a new Feature-Class. The feature-class is shown on the left as "New Feature".

Rightclick on "New Feature" --> Start editing 

But the segments are just deactivated (see screenshot). How do I activate them?

Thanks a lot for helping! Thank you so much.

Greets

0 Kudos
9 Replies
DanPatterson_Retired
MVP Esteemed Contributor

In ArcMap, you have to start an Edit session, by selecting the layer in the table of contents, then selecting Start Editing from the Editor toolbar (which I presume you added from the Customize,toolbars, menu option.  As a side note, in ArcGIS Pro, features and attributes are always at the ready to be edited without much fuss at all

AlexanderKrawczyk
New Contributor

Thanks for your message. That's what I did. Edit session started, but "Straight Segment" etc. still deactivated.

0 Kudos
Luiz_AmadeuCoutinho
Occasional Contributor III
MitchHolley1
MVP Regular Contributor

If you're just trying to add new line feautres to your Feature Class, you can use the 'Create Feautres' window.  See below: 

Make sure the layer is turned on in the Table of Contents. 

Click the layer you're wanting to add features to in the 'Create Features' window. 

Then, just draw your new features

AlexanderKrawczyk
New Contributor

Thanks mates. I've read the tutorial and I actually already know how it works (I thought I know )

The problem is, when clickling on the create features button, just nothing happens. No new window appears. Just nothing happening. What's that? Thus editing segments not possible. Editing is started.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

that screen shot isn't useful... go to the Editor toolbar, and click on the little drop-down arrow beside the word Editor... what does it show?  Also close arccatalog, may the dialog is underneath or it is offscreen

0 Kudos
KaylaFlamm
New Contributor III

Inferring from your screenshot, you have started an edit session (since the black pointer for the Edit tool is activated). Now you need to open the Create Features window. To do that, see below for two ways to do this:

If the Create Features window does not pop up, try finding it in a docked tab, or perhaps it is hiding under the Catalog menu to the right in your screenshot.

Also, FYI: the straight segment, end point segment, and trace options are greyed out because they can only be selected when you are actively editing a feature.

Luiz_AmadeuCoutinho
Occasional Contributor III

did you see my second picture?

0 Kudos
AlexanderKrawczyk
New Contributor

Thank you!

Actually I just realised, that I was not that stupid (or maybe yes?).


Whyever the "Create Features" did not pop up at work today. Whatever I did, it was not possible for me to get access to the segments, although an edit session was activated. I do not know why.

When I tried this at home, everything was normal. The "Create Features" window popped up and I was able to create segments.

 I need to figure out the problem when I'll be back at work on Monday.

Thanks anyway.. Propably I'll reactivate the thread on Monday Probs for this awesome community!

0 Kudos