Extract Multi Values to Points Runs but Removes Feature Class When Run as Tool

112
1
06-14-2019 11:09 AM
NealBanerjee
Occasional Contributor

Hello,

I have a fairly simple model that creates a subset of a point feature class using the 'Select' tool, and then assigns raster values for 7 different rasters using the ' Multi Values to Points' tool (see below).  When I run it in the ModelBuilder interface everything works fine everytime.  However when I run it through the toolbox, it seems to run fine (see 2nd graphic), but it deletes the feature class that it creates, so essentially does nothing. 

Any ideas why this may be happening?  Ive confirmed that the output feature class that it writes is not 'Intermediate'.  I only have this problem with this tool.  There is very frustrating as Im trying to run this in a series using a batch script tool, but it creates the process to fail

Any insight/help would be greatly appreciated!

Neal

0 Kudos
1 Reply
curtvprice
MVP Esteemed Contributor

Right click tmpkmeHML and make sure it isn't set to "Intermediate". That's probably the issue.