Raster does not display when zoomed in beyond a certain scale in a Mosaic Dataset

9782
16
Jump to solution
12-14-2015 04:13 PM
Labels (1)
JoeBryant2
Occasional Contributor II

I am having a problem viewing raster images in a Mosaic Dataset I created
when I zoom in beyond a certain scale. After I zoom in past 1:3,462 ft., the
image turns black
. I have created other Mosaic Datasets of
ortho-imagery before with success, but these rasters seem to behave
differently.  These are 1 band, black and white TIFFs with a single bit
pixel depth that represent scanned base maps. (They were already geo-referenced
by a previous firm and display correctly in our old GIS). Properties lists the
format as AMD, the SourceType as Generic, the PixelType as unsigned integer,
the Pixel Depth as 1 bit, and NoData Value is blank.

When I created the Mosaic Dataset I selected Create Overlays, Statistics,
and Pyramids and I used “NearestNeighbors”. I did not input any values for
Pyramids but left the optional fields as 0 or blank so that ArcMap would
calculate the values for me. The imagery displays fine when zoomed out.

I have cleared the visible scale range.

I have checked that the TIFF displays properly when zoomed-in using Windows
Picture viewer.

I originally created the Mosaic from the set of TIFFs that were on my local
hard drive. Everything worked except the zoom. The paths to the source rasters
were intact when I exported the path list.

I then copied the TIFFs to a subfolder on the same instance of our server
that contains our SDE database and the Mosaic Dataset. I repaired the
paths so they would point to the server copy. This worked as expected but did
not fix the zoom (no change).

I then looked into the cell level values in the attribute table. For the
Primary rasters the MinPS was 0, the MaxPS was 3.004587, the LowPS was just
less than .5 and the HighPS was just less the 1. The first level Overviews
picked right up where the Primarys left off with a Min, Low and HighPS of 3.004587
and a MaxPS of around 9. These values incremented as expected into the 2nd
through 4th level Overviews. For reference I’ve attached a
screenshot of the table.

To double-check, I added the rasters to the Mosaic Dataset again from their
new location on the server in order to re-calculate the pyramids, overwriting duplicates.
This worked as expected but still displays exactly the same with no change.

I am wondering if this has to do with read access issues. I found a
reference to UNC paths by Jake Skinner in a thread regarding how to create
Mosaic Datasets: “When you zoom into a large enough scale,
the overviews are no longer used, the raw imagery is.  Also, it is best to
load your rasters into the mosaic dataset using UNC paths (i.e.
\\servername\rasters).  That way ArcGIS Server and other client machines
can access the images when zooming into a large scale.”

I’m not sure what this is distinguishing;
my pathname is \\cwdgis01\mapping\pictures\ScanBase.
The “\pictures” folder path works as it is where I store attachments for pop-up
windows.

Thanks in advance for your help!

_joe

0 Kudos
1 Solution

Accepted Solutions
CodyBenkelman
Esri Regular Contributor

Joe

I'm guessing the problem is the 1 bit dynamic range, and ArcGIS is attempting to display 8 bits - therefore every pixel with values of either 0 or 1 would naturally appear black.  I expect your overviews are 8 bits/pixel.

Have you tried turning on dynamic range adjustment (DRA) in the Image Analysis Window?  That may not be an acceptable long term solution ("turn DRA on") but I'm hoping to confirm the images do appear.  I'll need to ask advice of others here to confirm the best way to work with 1 bit data.

Any chance you could send a sample file, even if it's very small?

Thanks

Cody B.

View solution in original post

16 Replies
JoeBryant2
Occasional Contributor II

FYI: ArcMap/Catalog/Server 10.3, SQL Server, Windows 8.1 64-bit.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

moved to Imagery and Remote Sensing to increase the chances of getting it answered

GeoNet Community Structure

JakeSkinner
Esri Esteemed Contributor

Hi Joe,

Have you tried repairing the mosaic dataset to use UNC paths?

When accessing a mosaic dataset from a client machine, and zooming into a large scale, the raw imagery will be returned.  If the images are loaded with the absolute path, C:\mapping\pictures\ScanBase, the client machine will look on it's local drive for these images.  When in fact the images reside on the cwdgis01 server.  Specifying a UNC path will tell the client to look on the cwdgis01 server.

0 Kudos
JoeBryant2
Occasional Contributor II

Yes, I believe I have done this. I just exported the pathnames again to check, and they are listed as "\\Cwdgis01\mapping\Pictures\ScanBase\338-185.tif."

Originally, the mosaic dataset was created in our Enterprise Geodatabase on our SQL server, but the TIFFs were located on one of my personal drives on the network: "Z:\...". When this did not work at large scales, I copied the files to a folder we have setup for attachments on our server. I then used the "Repair Mosaic Dataset Paths" tool and copied the UNC path listed above to the new path.

When this didn't change anything I used the "add rasters to mosaic dataset" tool with the "Overwrite_duplicates" option. During this step I also allowed Arc to set it's own values for generating new Pyramids.

Should I maybe ditch this mosaic dataset and make a new one from scratch instead of trying to repair/update it? What pyramid and overview settings might you suggest if not the defaults? Nearest Neighbor? This is a one band, (black and white with no grey),1 bit pixel depth scan of a base map of water utility assets. It will be displayed instead of aerial imagery or street/parcel views with our lines and points displayed on top when more detail about original conditionals is needed. In fact, the overviews are pretty useless - all I really need is the zoomed in detail.

Thanks.

0 Kudos
JoeBryant2
Occasional Contributor II

Looking through more related posts on GeoNet, I see that other users have a similar issue when adding a 1 band raster to a multiband Mosaic Dataset (image displays black).

The properties for my Mosaic Dataset do say that it is 1 band. But something interesting in the statistics I see is the range of values: 0-255. Does this imply it is looking for an 8-bit pixel depth? My TIFFs are 1 bit ("0" or "1": black or white). 'Not sure why the overview would generate and work correctly though. Grasping at straws here...

0 Kudos
CodyBenkelman
Esri Regular Contributor

Joe

I'm guessing the problem is the 1 bit dynamic range, and ArcGIS is attempting to display 8 bits - therefore every pixel with values of either 0 or 1 would naturally appear black.  I expect your overviews are 8 bits/pixel.

Have you tried turning on dynamic range adjustment (DRA) in the Image Analysis Window?  That may not be an acceptable long term solution ("turn DRA on") but I'm hoping to confirm the images do appear.  I'll need to ask advice of others here to confirm the best way to work with 1 bit data.

Any chance you could send a sample file, even if it's very small?

Thanks

Cody B.

JoeBryant2
Occasional Contributor II

Cody,

I've attached one of the TIFF tiles along with it's world file and .aux.

I also attached another screenshot in the same properties window for the Mosaic Dataset, but showing the Raster Information at the top rather than the 1-band stats at the bottom. It shows that the raster does have a Pixel Depth of 1 bit.

Let me try the DRA... give me a few...

0 Kudos
JoeBryant2
Occasional Contributor II

Turned DRA on and that did work, Cody. Thanks!

You mentioned that might not be a good long term solution; why?

Any thoughts on the (technically) correct way to setup this Mosaic?

I would like this layer to be zoom-able when served in a web map via our Portal.

0 Kudos
CodyBenkelman
Esri Regular Contributor

Joe

sorry for the delay - always busy here

When you created the MD, did you specify Pixel Type = 1 bit?  If you do this, the Overviews will still be created as 8 bit JPGs but ArcGIS knows that the statistics of the source raster are different (values of 0 and 1 only) and should display both overviews and original rasters properly.

1BitMD.jpgMy comment about "May not be the long term solution" was simply acknowledging that I hadn't asked how many users you have and if they're all using ArcGIS or if they might be viewing a variety of web clients to view the data... 

Cody

0 Kudos