will Raster Calculator ingnore null values?

2203
6
Jump to solution
03-27-2013 08:39 AM
DavidMedeiros
Occasional Contributor II
I have a stack of rasters (daily UV values for a year). I need a yearly average raster but my input daily rasters contain null values through out each raster at various locations.

If a cell stack has a null in it I still need the average of the remaining cells with real values, but not an average that counts the null cells for division. Will the Raster Calculator ignore the null value cells in the average or will it count that cell in the denominator value for the average function?

I see that Cell Statistics has an option to ignore null value cells, which reads like it would be what I want but their graphic example seems to suggest that what it does is ignore the entire cell stack if one cell is null.

http://resources.arcgis.com/en/help/main/10.1/index.html#/Cell_Statistics/009z0000007q000000/
0 Kudos
1 Solution

Accepted Solutions
DanPatterson_Retired
MVP Esteemed Contributor
Did you try the "DATA" option?

View solution in original post

0 Kudos
6 Replies
DanPatterson_Retired
MVP Esteemed Contributor
Did you try the "DATA" option?
0 Kudos
DavidMedeiros
Occasional Contributor II
Did you try the "DATA" option?


I just ran a test with the DATA option on a set of three dummy rasters: value1, value2, and valueNull. The result for mean should be 1.5 if the null values are being ignored, instead I got an output raster of Nulls. So that mean it ignore the entire cell stack, not just the individual null cells.
0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor
and the other option yielded the same results?
0 Kudos
EricRice
Esri Regular Contributor
Hi guys,

The graphic is wrong and I've talked to the tool owner to have him update it.  The tool, however, seems to be working as it should. See screenshot attached.  I'm using 10.1 sp1 for this test.

Best,
Eric
0 Kudos
DavidMedeiros
Occasional Contributor II
Did you try the "DATA" option?


I thought I did but must have miss checked the box. It works as described, not as pictured, meaning the tool does in fact ignore individual cells of no data and not the entire stack of no data cells. ESRI should update the image to match.
0 Kudos
DavidMedeiros
Occasional Contributor II
Hi guys,

The graphic is wrong and I've talked to the tool owner to have him update it.  The tool, however, seems to be working as it should. See screenshot attached.  I'm using 10.1 sp1 for this test.

Best,
Eric


Just saw this after posting above, thank you for your reply.
0 Kudos