While clipping data empty layer generated as output

26099
12
04-27-2010 10:10 PM
Antonypaul_m
New Contributor
Hi Guru's

I was trying to clipp data from street layer based on one county. I have created tge county boundary as shape and run the clipping. But unfortunately it created empty layer as output with following error,

000117: Warning empty output generated

Source layer cordinate is GCS_NAD_83
Clipp layer Shp cordinate GCS_NAD_83

When I searched I am getting the following note from dekstop help,

Error code: 000117: Warning empty output generated.
Description:  The output created or modified has no featu
res. For instance, running the Delete Features or Delete Rows tools on a feature class or table would remove all the features and rows. A common occurrence of this warning occurs when the Extent (or XYDomain) environment has been set previously for a geographical distinct area. Since the Extent environment is used to limit the features used, an inappropriately set Extent environment could exclude all features.
Solution: If this warning is unexpected, check the Extent environment to ensure that it is appropriate for the data being used.

Could anybody please help me out


-Thanks
Antony
0 Kudos
12 Replies
DeepikaJain
New Contributor III
Hi Antony

Will it be possible for you to upload the data...
0 Kudos
JU
by
New Contributor
Are you using the ESRI Data and Maps CD street SDC data?  If so what area of the country are you trying to clip out?

Check the extents of both the clip feature class (county boundary) and the streets to make sure they are both in the same coordinate system and the extents make sense. 

Also, where are you doing this?  ArcToolbox in ArcMap or through a model?
0 Kudos
GregYetman
Occasional Contributor
I had the same issue with two polygon layers. I converted the clip layer from multi-part polygons to single-part polygons and it worked ok after that.

Greg
0 Kudos
PeteWalsemann
New Contributor
I am having the same issue with Desktop 10.3 [ArcMap].
Two polygon layers, sharing the same projected coordinate system [and the same as the map document] and one dataset is partly contained in the other.  I am trying to use the former to clip out a section of the latter and keep getting the empty warning.  I did this previously with another dataset and corrected the error by reprojecting one set of data to the same coordinate system.  I did so with this set and it produces the error.

I have cleanly reprojected the data and then added that data into a new map of the appropriate projection and still get the same warning.

Do you have any ideas on a solution?
0 Kudos
YahiaKala
New Contributor
I got an error trying to convert multipart to single part polygon, so I used the Repair Geometry tool. I was then able to convert multipart to single part polygon, and it solved the problem.

I also tried to use repair geometry without subsequently converting multipart to single part polygon, and it also worked.
AlderMaps
New Contributor III

Repair Geometry solved this error for me; thanks!

0 Kudos
SandraToepsch
New Contributor

Hi everybody,

as I landed here with the same warning message, I could fix my problem as following:

in my case the root cause, why the clip-analysis-tool was not working properly without the message „000117: Warning empty output generated”, seemed to be an entry for "definition query" in the layer properties: I just want to use a subset of my input features. After exporting the desired subset into an extra feature class and using this one as input features the problem was fixed.

My working environment:

•             ArcGIS 10.2 Advanced

•             Input features: File Geodatabase Feature Class, WGS84

•             Clip features: Shape File Feature Class,WGS84

•             worked with Python Window

•             Environmental settings: no extra settings

Cheers, Sandra

0 Kudos
EdithKonopka
New Contributor III

Thanks everyone for helpful hints! I was trying to run clip in ArcMap 10.3.1, using a query layer county polygon to clip a statewide road feature class, and kept coming up "empty". Converting the query layer to a standalone single polygon feature class did not solve the problem, but running the Repair Geometry tool on both single county and road feature classes did. I was successful running clip tool from ArcCatalog.

0 Kudos
sydneyday
New Contributor

I had the same problem and I used repair geometry and now I am able to clip the data with no Warning message! Thanks!

0 Kudos