What license do I need to use background processing 64bit?

496
7
02-26-2018 05:00 PM
성환조
New Contributor

I got a error message 'Tool is not licensed' When I tried to execute hotspot on the background processing 64bit environment. Foreground processing works without problem.

What license should I have?

0 Kudos
7 Replies
DanPatterson_Retired
MVP Esteemed Contributor

Check your Customize, Extensions menu option and make sure that the Spatial Statistics is toggled on.

http://desktop.arcgis.com/en/arcmap/latest/tools/spatial-statistics-toolbox/optimized-hot-spot-analy...

성환조
New Contributor

I appreciate your quick reply. I did toggle on all of the extensions so that It works without 64bit background processing but the message was shown for all arctools with background processing after I installed the 64bit background processing.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

What version of ArcMap?  Could be a bug or some other issue... but

If you need 64 bit, it is just easier to use ArcGIS PRO... the same tools exist there for the most part and it will honor your licenses that you have for ArcMap.

0 Kudos
성환조
New Contributor

The version of ArcMap is 10.3.1. I am not sure my institute has ArcGIS pro.

Because of many of mxd files, I am trying to use ArcMap.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

You would have to backtrack through the changelogs to see if this was an issue that was addressed in other releases.

I maintain a changelog under Bug List and Changelogs on my blog

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

3 workarounds to a similar issue

  • Disable 64-bit background geoprocessing
  • To continue using background processing, remove 64-bit background by uninstalling it. Tools execute in the 32-bit space when background processing is enabled.
  • To continue using 64-bit background, contact Esri Technical Support to investigate this issue. 

Error: You are not licensed for Geodatabase Editor 



Think Location
RebeccaStrauch__GISP
MVP Esteemed Contributor

I agree with Jayanta and Dan.  Background 64-bit processing with 10.3.x seems to cause more issues than it is worth.  Turn it off and see if that makes a difference.

0 Kudos