using feature iterator in model using lastools functions

05-28-2014 03:30 AM
New Contributor
I have a question about using iterators and lastools functions in the arcgis modelbuilder.

I use ArcMap 10.1 and the LasTools ArcGIS toolbox.
So far, using lasfiles and lastools functions in the modelbuilder has worked fine.

I'm trying to clip the lasfiles onto shapefiles of single trees in a forest, and export these lasfiles to txt. I have two lasfiles, one with ground returns and one with nonground returns.

To avoid having to adapt and run the model once for every tree (there's 200+ trees in my forest plots), I have tried to incorporate a feature iterator. However, the lasclip function does not seem to accept the output feature of the iterator as input. I cannot select the iterator output in the lasclip tool interface and when I try to build a connection between the iterator output and the lasclip function, I cannot select the "input feature" option.

Has anyone encountered similar problems? Are the lastools functions incompatible with iterators?

Thanks in advance,

PS. I'm only a bachelor student and I don't have much experience with the modelbuilder..
0 Kudos
0 Replies