Union tool in Model Builder

11-14-2013 10:08 AM
New Contributor
I am trying to union together two polygon shapes in model builder.  One is a model parameter, the other is created at an earlier step in the model (using ETGeowizards)  I can union the two shapes together in ArcMap just fine.  However when I try to connect them to the Union tool in my model, the parameter polygon will connect, but the model-derived polygon will not connect as an input to the tool, I only get the environment or precondition option.
The last piece of information is that the model-derived polygon is named using an in-line variable (%name%)  I mention this because when I create a totally new model with the union tool and browse directly to my model-derived polygon (from a previous test run of my model)  I am able to connect it and run the union tool. I did think about just making the union tool a sub model, but I would rather not have to do that and even when I tried it, I got the same error (although I've never really worked with sub models so its possible I did something else wrong) 

What am I missing?! 
0 Kudos
0 Replies