Union in Model Builder does not merge polygons. It copies them as they are in the source layer

944
6
11-03-2021 02:16 PM
JoseSanchez
Occasional Contributor III

Hello everyone,

I am looking for a way to merge all the polygons with a specific condition in another polygon layer.

I am creating a feature layer with a subset of  the polygon feature class and when I run the Union the final result does not merge the polygons I selected.

This is what I am doing

in Model Builder

 - Select all polygons from FC grid polygon  that are located in Area =1

 - run Union tool

This creates a new FC that  shows the same subset, not the expected result only 1 polygon.

What am I missing?

Thanks

Jose

0 Kudos
6 Replies
DanPatterson
MVP Esteemed Contributor

When you say 1 polygon, do you mean....

Dissolve (Data Management)—ArcGIS Pro | Documentation


... sort of retired...
0 Kudos
jcarlson
MVP Honored Contributor

I'd suggest reading through the Union documentation, but the image from that page sums it up well enough:

 
 

jcarlson_2-1635974627723.png

What you are describing sounds more like Dissolve Boundaries.

- Josh Carlson
Kendall County GIS
0 Kudos
MehdiPira1
Esri Contributor

@JoseSanchez ,

Try Dissolve instead of Union.

0 Kudos
DanPatterson
MVP Esteemed Contributor

That has already been suggested....


... sort of retired...
0 Kudos
JoseSanchez
Occasional Contributor III

Thank you for your answer Mehdi and Dan,

I am confused because with ArcMap I am able to select the same out put layer, open an edit session, select all the polygons form my select, run the Union and it merges all the polygons in one.

 

So the Union in ArcMap does not work the same way as the Union in ModelBuilder.

 

 

 

 

 

0 Kudos
DanPatterson
MVP Esteemed Contributor

An edit session is a different environment than modelbuilder and their behaviour isn't the same


... sort of retired...
0 Kudos