split features tool error

10-28-2020 06:57 PM
New Contributor II

I am unable to get this tool to work for me at all. I am trying to split one feature using another polygon and I constantly get "There was an error during processing", with no specific details. The splitting feature and the target features are both  feature classes in the same geodatabase in the same projected coordinate system. The cutting feature is selected (I have also tried selecting the target features). 

I noticed that the tool has "USE_TARGET_Z" despite neither layer having Z values, but I have tried to use a python script and explicitly stated DONT_USE_Z_VALUES, and had the same result, so I don't think this is causing the error.

I would like to create a script and custom tool using this function as I often need to split a feature using another feature but cannot get this tool to work, any help would be appreciated.

Tags (2)
0 Kudos
4 Replies
MVP Frequent Contributor

Projection etc all ok? Do you have write access to your dataset being split?

0 Kudos
Esri Contributor

Hi Andrew,


I am sorry you are encountering issues with the Split Features GP tool.


I work on the ArcGIS Production Mapping and ArcGIS Defense Mapping Teams. I usually monitor those places in GeoNet. I just saw your question in Geoprocessing.


Can you please answer the following questions:

1. What version of ArcGIS Pro are you using?

2. The cuttingfeature and mapping feature classes reside in a file geodatabase or enterprise geodatabase?

3. What is the coordinate system of the cuttingfeature and mapping layers?

4. Would you be able to provide the mapping feature class?

5. If you were able to successfully execute the Split Features GP tool, what would have been the next step in your workflow for the features in the mapping feature class that are within the cuttingfeature boundary?


I hope to hear from you.







0 Kudos
New Contributor II

Hi Dan, 

I was wondering if the issue was addressed or fix. I also can not split features using the "Split Features" geoprocessing tool. Error returned:

There was an error during processing.
Failed to execute (SplitFeatures).

To Note: 

ArcGIS Pro 2.7.1

Both Features have the same projection (anyway will not work if not so)

Both features are in the Geodatabase

Both Features are editable. 


0 Kudos
Esri Contributor

Hi Juan,

Thank you for reaching out through the Esri Community.

I am not able to reproduce the issue raised by Andrew.

Are you able to provide the data?

Have you run the Integrate tool using the Cutting Features and Target Features parameter values to help ensure spatial integrity before using this tool. This is especially important when complex polygon features are involved.

Does the Check Geometry tool report any issues?



0 Kudos