Script error (invalid pointer) in Windows 10, any browser when using Toolbox tools (e.g., Create address Locator)

3619
2
04-21-2016 07:54 PM
JanEvans
New Contributor

I am on a Windows 10 machine, ArcGIS Desktop 10.3.1, using Edge, IE 11, Chrome and Firefox as the default browser to troubleshoot)

I was able to use two tools successfully ("Feature Class to Feature Class" and "Create Address Locator") at least once. At some point, for some unknown reason, when I tried to use these tools again, I get a script error:

     An error has occurred in the script on this page.

     Line: 47

     Char: 4

     Error: Invalid pointer

     Code: 0

     URL: file:///C:/Users/<username>/AppData/Roaming/ESRI/Desktop10.3.1/ArcToolbox/Dlg/MdDlgContent.htm

I have googled this error and found various suggestions to resolve it, tried many of them, but still cannot resolve the issue so I can use these tools.

I know from casting about on the web that this is a common problem. Has ESRI addressed this issue or does ESRI suggest a workaround?

0 Kudos
2 Replies
DanPatterson_Retired
MVP Esteemed Contributor

since you didn't specify what you tried.... the only common link that was resolved involved firefox and the error.  But I am sure you have seen the link.  I use Edge with 10 (and nothing else) and have never had issues with any of the tools in Arcmap

Opened a ticket with ESRI support - It seems the issue arrises from having Firefox as your default browser (and not IE). "I think the MdDlgContent.htm file gets opened with an MSXML Parser. I imagine that the software couldn't find a Parser plug-in compatible with Firefox."

0 Kudos
JanEvans
New Contributor

Thanks for the reply. I tried the following:

1. Switched from Chrome to Edge as the default browser

2. Switched from Edge to IE11 as the default browser, adjusted the security

level from med-high to medium, and then deleted the ESRI profile

folders in C:/Users/ and then rebooted

2. I also tried the tools with FF as the default browser

I was able to use both tools successfully originally with Chrome as the

default browser. Something happened to render them useless due to this

error.

Thanks again.

0 Kudos