Route event layer won't show up

900
3
06-25-2018 08:11 PM
ElleCee
New Contributor

I'm trying to create a route event layer based on point data of places a list of people visited. The number of points per person varies, but each person has more than one point. I was able to create a route shapefile, but I'm having trouble making the route event layer. Although the route event layer appears in my table of contents and I can open its attribute table, the layer doesn't show up on my map, even when I zoom to the layer or zoom to an attribute. I've tried creating the route event layer using a table with only two points per person (in case the different numbers of points per person were the problem) and I got the same results. Does anyone have suggestions?

Tags (1)
0 Kudos
3 Replies
DanPatterson_Retired
MVP Esteemed Contributor

The usual questions...

Software?

Was the data added alone without any other files (like a basemap)

If other data were co-mingling with your data, what are the coordinate systems of all the inputs?

Have you tried adding it to a dataframe/map (arcmap/ArcGIS Pro)?

Any other pertinent information

0 Kudos
BlakeTerhune
MVP Regular Contributor

You posted in the GeoNet Resource Hub. Tagging Analysis and Geoprocessing for better visibility.

0 Kudos

Take your point layer and run "locate features along routes" to create the event layer - I'm assuming you've done this and that's how you got your event table.

Next, run "make route event layer" and make extra sure you put in all the correct parameters for route identifier and measure, also choose to generate a field for locating errors.  It's really easy to miss one of those parameters and get the result you came up with.  Look at the error field.  Also, depending on what software/system you're using and how many points there are, it might help to export the event layer to a feature class for checking results, sometimes the route event layers don't display immediately in ArcMap.  

0 Kudos