Recurring error 000117 : Empty output generated using geoprocessing tools...

23040
11
09-14-2010 08:37 AM
FélixBrochu_Marier
New Contributor
Hey everyone.

I've been using arcMAP10 for 2 weeks now and i'm having a lot of problem with geoprocessing tools. Most of the operations i've tried (unions, intersect, clips) generate empty outputs. I've been reading on environment settings, and I have to admit I don't understand most of them since i'm not such an advanced user. I've never modified any of those but it seems my problems originate from them. Last week I found a workaround by putting the two standalone shapefiles I was trying to union in a geodatabase. I understand this might have solved the problem because the two shapes must have had two different extents. (?)

However, I'm still stuck with other problems of the like. Right now i'm trying to merge a couple shapefiles that are actually exports from one mother-shapefile. I still get an 000117 error, and when I try to import them in a geodatabase using the feature class to geodatabase (multiple) tool, they loose their content. They all have the same coordinate system. I must be missing something ?

Is there a way to set the environment settings so they won't hinder my work any longer? I don't recall having this kind of problems in previous versions!

i'm joining two of the shapes to merge, just in case.
0 Kudos
11 Replies
KimOllivier
Regular Contributor II
Try turning of the ArcGIS Desktop Index Service. This has been a strange fix, but proven for this error message.

(Use Google desktop indexing for searching if you need to search)
0 Kudos
FélixBrochu_Marier
New Contributor
Kimo,

Thanks for replying. My problem seems to come and go, most days everything works fine, sometimes it doesnt. Now, I thought this kind of error only occured because of a conflict with Quicktime, wich I don't have installed on my computer (including itunes). Anyhow,next time my geoprocessings fail, I will try what you suggest!

thanks!
0 Kudos
GeoffKlise
New Contributor III
I would like to add to this post. I'm trying to do a merge on a bunch of shapefiles (ArcGIS 10) that all have the same field properties. It worked earlier, now it does not. I checked the environment settings, no problems there.

The quicktime issue came up with me about 2 months ago where I kept getting a desktop indexing error. I uninstalled it (according to the tech support person at my place of employment) and the error went away. I'm not sure how it relates to ArcGIS, but I find it problematic that an indexing service (on vista?) would be causing this error. Any suggestions ESRI?
0 Kudos
ChrisSnyder
Regular Contributor III
Did you accidentally set a default value for the Extent environment variable (a specified xy rectangle for which all geoprocessing tools will perform within)? I inadvertently did this a while back and had a hell of a time figuring out what I did to make all my outputs come back with no results.
0 Kudos
MichaelPorter1
New Contributor III
I got this error when there was a space in a directory name on the path.  Trying moving your data to c:\temp or another directory without spaces.
0 Kudos
AdamBonnycastle
New Contributor
I just had a similar problem trying to intersect to polygon shapefiles.  Running Repair Geometry did the trick.
0 Kudos
ChrisChapman1
New Contributor
Hi,

I had a similar problem with the intersect tool, repair geometry worked for me too.
0 Kudos
XunjingWu
New Contributor

Repair geometry worked for me too!Thank you for the answer!

0 Kudos
BramVan_Helleputte1
New Contributor II

I'm having the same issue with the select by location tool, and repair geom didn't do the trick

-selected layer is a line feature layer from an oracle spatial table

-selecting layer is a query layer from oracle spatial point table, layer containing only 1 point resulting form query => saved to disk with the copy features tool

-relation is intersect, with a radius of 50m

ArcgGIS version is 10.1 fyi

No sde used

What am I missing here?? I first thought it was due to differences in the geometry fields, because I had the same error with a self-drawn point feature class.

Weird thing is that it DOES work with a previously exported point form the database, which has exactly the same schema as the one I'm querying now...

Should I try a different export tool to materialize the query layer?

Would love some help on this! 🙂

Thanks!

0 Kudos