"Export to different raster" from mosaic dataset help

08-15-2017 08:01 AM
Occasional Contributor

Is anybody having issues using copy raster or “Export to different raster” from the mosaic dataset menu?

Specifically trying to adjust the environmental compression quality settings?

Hoping to resolve this issue I even upgraded from 10.3.1 to 10.4.1 but it seems that the issue still persists… or possibly I’m missing something.


I’ve been looking to mosaic two countywide raster’s together from 2 different years one is a 18in per pixel the other is a 12in  per pixel. Both are 3band 8bit unassigned rasters and Both raster’s are in the same coordinate system.

The older and lower resolution raster is a .jp2 and represents a larger area as it includes an extra mile buffer area around the county.   The new higher resolution a.sid and represents an areas of just the county boundary.  

The goal is add the extra 1 mile buffer area old raster to the new higher resolution raster.  Nothing fancy no seam blending or color balancing is needed… just a simple one raster on top of the other.


Looking at the mosaic dataset properties the uncompressed size is 104.72gb.

The source input rasters Individually are:

The uncompressed .jp2  raster is 47.58 GB, compressed its size is 2.48 GB

The uncompressed .sid  raster is 85.59 GB compressed its size is 2.56 GB


Attempts to use “Export to a different raster” from the mosaic dataset menu are resulting in very large .jp2 rasters.

The first attempt resulted in a 37 GB jp2.

That being much too large I ran several tests with smaller raster’s and found that using the copy to raster tool or “Export to a different raster” resulted in the same result regardless of what I set for the compression quality.  Meaning I could use a compression quality of 3 or 80 and they output file would be exactly the same size.


I found that directly from Arcmap 10.3.1, using “export raster data”  to a jp2.  would correctly compress and export the  mosaic raster.  The result was a 12 GB file…  However using this process the footprints/seamlines are not persevered in process.  I found that my Nodata and ignore background value now impacted the entire raster with all 255 white pixels being dropped.


For my latest attempt I upgraded to 10.4.1. This attempt is still currently processing but it looks like the result will be exactly the same as my fist attempt.  Currently the file is 27.5 GB and counting using a compression quality of 6.  Generally

.jp2 seems to offer the good compression which is why I trying  to use it.  Using .sid would be great but we don’t have the software to process it.


The output raster is just going to be used as background reference image so minor loss of data quality isn't much of a factor. Ideally I would like to get a raster in the 5 GB size range.

Any thoughts... I would like to understand whats going on.

Am I missing something?

Attached is geoprocessing settings for the current export task.  

Thanks in advance.

0 Kudos
0 Replies