Problem with intersect and split tools

653
6
08-24-2018 01:37 AM
MarijaBogdanova
New Contributor II

Hi!

I've been given a file geodatabase with many feature classes to fix some topology errors, including errors concerning roads and railroads. Those should be split at intersections and also there should be points at those intersections. 

Intersections and points were sort of corrupted when the data was prepared (I assume, or may be it was never correct): not all intersections and points are present, a lot of them are dislocated.

So I'm trying to fix this - by creating new points at intersections (using Intersect tool), then spatially joining them with some old floating intersection points from the original data to preserve the original attributes, and later using the points to split the lines in the right places. 

Problems are:

- Intersect creates some points that are floating next to the intersections

- Batch Intersects and Splits Polylines from Production Editing Advanced also doesn't split the roads/railroads at intersections (with both checked in the window)

The attached image shows the lines (orange one is the road - it is not split, and rail is split but in the wrong place (original data); the point next to them was created by Intersect tool)

I'm using ArcMap 10.3.1, might be possible to access 10.6 if anyone thinks it is the only way

I'm also not in a position to share the shapefiles, since I work for the government.

Thanks!

Marija

0 Kudos
6 Replies
NeilAyres
MVP Frequent Contributor

Shouldn't you be using Union rather than Intersect?

I don't understand why the point is not exactly at the intersection point. That doesn't make sense.

But would "Planarise lines" in the Advanced editing toolbar do what you want?

0 Kudos
MarijaBogdanova
New Contributor II

Hey, Neil

I thought Union doesn't have a point output option. Intersect does, though.

Tried to planarize lines, it also didn't work with these two layers.

since planarize didn't work with two layers, I have a new idea now - I will try to merge Roads and Railroads layers together and dissolve them, and then planarize that one layer.  After that I could spatially join the one layer with the old attributes and divide all back into two layers. In case this works, I will try to use Intersect again.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

Both are in the same coordinate system I presume?

If that image is zoomed in really close, it may be a visual artifact since the point wouldn't be created.

what are some of the gdb properties like feature tolerance, xy resolution etc

Feature class basics—Geodatabases | ArcGIS Desktop 

MarijaBogdanova
New Contributor II

Hey, Dan. Yes, the coordinate system for both is GCS_ETRS_1989. Feature classes were originally in other system and were converted (I wasn't the one doing it, though). 

It isn't a visual problem - I used Select by Location on those points, they really don't intersect the roads/railroads.

Here on the screenshot are some infos you ask for, I believe. 

Files in this geodatabase have a wild extent (I don't know why, seems to be because they are made for a European map project gathering data from all the countries)

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

those coordinates are certainly not in degrees

I suspect a Define Projection was used rather than a Project

0 Kudos
NeilAyres
MVP Frequent Contributor

That's the domain, not the extent.

They probably are degrees. But it does look rather odd.

0 Kudos