prevent automatic bit-depth promotion?

275
1
08-13-2013 11:46 AM
kevinbrown1
New Contributor
I have 2 rasters:

1) 2-bit .tif with 3 as the NoData value.  Only needs to express 0,1,NoData
2) 1-bit .tif with 0 as the NoData value. Only needs to express 1,NoData

No matter what sort of analysis I perform on these, they are always promoted to 8-bit with a noData value of 255. This is unacceptable because the file size balloons to 7gb with the promotion.  I have found no solution to ensure bit depth is preserved. Having to use copy raster between every operation is not an option. I don't understand why this is happening, because I am not introducing any new values into the rasters through analysis.

Any ideas?
0 Kudos
1 Reply
MelitaKennedy
Esri Notable Contributor
Possibly set the geoprocessing environment NoData to PROMOTION. It's in the raster storage section. Based on the help, and if I'm understanding it correctly, that may do it. In the help, search for "nodata environment" (without quotes).

Melita
0 Kudos