Point Distance 999999 Error

701
2
06-22-2013 09:58 AM
NoahHammarlund
New Contributor
Hello,

I am a fairly new user. I am just trying to get the distance from hospital addresses to other addresses within a certain radius using ArcMap. I did the same thing with another set of addresses and got to the distance output just fine but this time I am getting an error. So far the steps I have gone through are:


  • used geoprocessing to get the x/y coordinates of the addresses.

  • created an xy feature class

  • projected on the geographic NAD83 plane using define projection

  • reprojected using feature/project on a UTM Projected

  • used the point distance tool with same file as input and near with the xy coordinates



The error I get says 999999 after 7 or 8 seconds of running the point distance tool. I cannot find much other helpful information from the message.

I am trying to save the output to the same folder as the table with the xy projection. I saw another thread post suggest creating a new gdb folder and saving the distance output there (link to that post: http://forums.arcgis.com/threads/35050-Point-tot-point-distance-gives-error-message). I tried that and the distance worked without an error, but I cannot seem to find any openable file when I look in that gdb folder in windows explorer but I do see the file in the catalog in ArcMap.
0 Kudos
2 Replies
NoahHammarlund
New Contributor
Does anyone have any ideas on the error or on getting the table from the .gdb? I'd be glad to provide any further information. Thank you.
0 Kudos
DanielHall_Ballester
New Contributor III
Check your file paths or all input/output data.
Do you have any invalid characters such as spaces?
Check all the way back to the root drive letter
i.e. C:\Users\Bob\My Documents
this has a space between "My" and "Documents".  This can sometimes make tools fall over.  Replace all spaces with something else (I use underscores"_")

Or do you have hyphens in the file names? "-"  Again, these will cause problems.

I hope this helps!
Dan
0 Kudos