Select to view content in your preferred language

New M aware error

04-20-2013 02:55 AM
New Contributor
(I have read and followed the suggestions mentioned in with no success)

Dear all,

For some inexplicable reason, I have - very suddenly (which is the weird part) - started running into "geometry is not M-aware" errors, and have been unable to perform many of the operations I was previously able to conduct, on the same datasets.

What is strange is that I have previously conducted a variety of these operations (intersect, overlay, convert to line, etc.) succesfully, but seemingly from one day to another, none of these operations work anymore.

I thought maybe my datafiles had been corrupted, but I have gone back to the original datasets, and even the most basic operations fail. For instance, using the following dataset (, I simply tried performing a 'feature to line' operation, which previously worked just fine, but now generates the M aware error.

I cannot think of what is causing this. I have tried different computers. The only change I can think of is that, since then, I am storing my files on a different drive as I no longer have access to the original one, but I have tried putting the files on an external drive, with no luck. I have tried this on different computers. The installation is a network-wide one to which I have no access/control, so no system settings could have been changed; and other users on the same network do not appear to have any problems.

Is this truly an 'M aware' error or is there some other, utterly unrelated, issue that may be causing this?

Your help would be appreciated since, at the moment, ArcGIS seems deadlocked.


0 Replies