Multi processing GP tools fails sometimes

365
2
08-09-2017 09:50 PM
ModyBuchbinder
Esri Regular Contributor

Hello all

We have some problems with some GP tools that uses multi processing, mainly the cache commands  Export Tile Cache and Manage Tile cache.

When you check the task manager when these tools run you see that ArcMap.exe create a ARCSOMP.exe process, then a few ARCSOCP.exe processes created (the  number of processes is by the multi processor env setting). These ARCSOCP.exe command really get the CPU and do the work.

On Some machine, some times I see the ARCSOMP.exe starts and no ARCSOCP.exe, after a few seconds I get 99999 error and the message is Configuration of RasterCommander.ImageServer can not be added.

Some time I can close ArcMap, reopen, do the same tool and it works. Some time I have to restart ArcMap a few times before it is running successfully again. I found no errors in the event viewer.

This happens on a few different machines in our office. We use ArcMap 10.3

Anybody have any idea? 

0 Kudos
2 Replies
DanPatterson_Retired
MVP Esteemed Contributor

this is an ...interesting read.... tread lightly.  References to problems related to this seem to have stopped a version or two ago of ArcMap, ... perhaps ask around internally with tech support to see if more recent versions of arcmap and operating system handle things differently and/or better.  Why not upgrade from 10.3?

0 Kudos
ModyBuchbinder
Esri Regular Contributor

No so simple I afraid. It took them two years to upgrade to 10.3 just a month ago...

0 Kudos