Invalid Topology [Undetected intersection.]

3038
2
10-25-2011 08:30 AM
AudreyH
New Contributor
Hi,

I am trying to use the clip tool to cut thematic polygons with each polygon feature class, defining district boundaries. For some district polygons, I'm getting the following error message:

ERROR 999999: Error executing function.
Invalid Topology [Undetected intersection.]
Failed to execute (Clip).

I don't understand this message because the two layers are well overlapped. Any ideas on how I can solve this problem ?

Thanks in advance.
0 Kudos
2 Replies
DanielAmrine
Occasional Contributor
Sorry I am not offering a solution!

I am getting the same error trying to clip simple rectanlges with a buffer i generated.  it worked just fine yesterday doing the same exact process with just a different Input Feature.

I've checked geometry, they are both feature classes from the same database.

I'm running ESRi 10.0 Build 4400 service pack 5
ArcInfo License
on Windows 7

ESRI please respond!!!

Dan

Update:

I exported all the files from feature classes to shape-files and saved it a folder outside of the databse. This worked just fine.

So Corrupted database?
0 Kudos
GreggRoemhildt
Occasional Contributor III

I was experiencing this issue when using the clip tool in Modelbuilder. Adding the additional step to convert to a shape file first, then clip worked perfectly for me.

0 Kudos